Unable to upgrade OpenLM server version: TS-OLMSRV001 KB - OpenLM Software License Management
Israel +972 4 6308447         USA +1 619 831 0029              JAPAN +81 505 893 6263 担当:萩原

Unable to upgrade OpenLM server version: TS-OLMSRV001 KB

You are here:
< All Topics

Symptom

The customer complained that after upgrading the OpenLM Server, the Server configuration form would not open.

 

Observed during investigation

The customer could not uninstall the OpenLM Server module. Although being set as an administrator with administrative privileges, he was denied the ability to uninstall the OpenLM Server service.

 

Solution

1. Back up the Database.
2. Uninstall the OpenLM server service, using a CMD file:

  • Compile a CMD file (e.g.: myUninstallFile.cmd) from the following code.
  • Run this CMD file as an administrator: Either from a command line, or Right-click on its icon, and choose to run it as an administrator:
// Stop the OpenLM Server service
net stop “OpenLM Server”
// Uninstall the OpenLM Server Service
“C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe” /u “C:\Program Files\OpenLM\OpenLM Server\bin\OpenLM_Server.exe”
// Wait for the user to click any key
pause

3. Uninstall the OpenLM Server Using the Windows Control Panel.

Note: The OpenLM server service may be reinstalled using a CMD file in a similar manner to that of the uninstallment process:

  • Compile a CMD file (e.g.: myReinstallFile.cmd) from the following code.
  • Run the CMD file as an administrator: Either from a command line, or Right-click on its icon, and choose to run it as an administrator.
// Reinstall the OpenLM Server Service
“C:\Windows\Microsoft.NET\Framework\v4.0.30319\installutil.exe” “C:\Program Files\OpenLM\OpenLM Server\bin\OpenLM_Server.exe”
// Wait for the user to click any key
pause

4. Restart the OpenLM server service.
5. Download and run the latest OpenLM server version (MSI file)

Tags:
Previous Unable to connect to FLEXlm license server error: -96,7:11004 “Comm. error”: TS-OLMSRV003 KB
Next What Flexnet version is ESRI ArcGIS using? – KB
Table of Contents