USA +1 866 806 2068 | JAPAN +81 3 45208991 担当:萩原 info@openlm.com

The current SLI session has terminated or was not properly initiated

Forums OpenLM for Engineering Licensing The current SLI session has terminated or was not properly initiated

Tagged: , , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1024
    hl

    Hello,

    we’re having an issue that every now and then some regressions fails
    it seems to be from the license area

    1st Error:
    Time: 0.0
    From: reporter
    Type: [LICENSING]
    Details: Encountered SLI error ‘The current SLI session has terminated or was not properly initiated’

    UVM_ERROR @ 0: reporter [LICENSING] Encountered SLI error ‘The current SLI session has terminated or was not properly initiated’
    UVM_FATAL @ 0: reporter [LICENSING] Unable to initialize licensing.
    UVM_INFO @ 0: reporter [UVM/REPORT/SERVER]
    — UVM Report Summary —

    ** Report counts by severity
    UVM_INFO : 1
    UVM_WARNING : 17
    UVM_ERROR : 1
    UVM_FATAL : 1
    ** Report counts by id
    [LICENSING] 2
    [TPRGED] 17
    [UVM/RELNOTES] 1

    I’ve checked the flexlm logfile but it shows nothing on this manner
    we’ve also disabled preemption from NC thought it was the root cause though NC happens to be OK
    if anyone ever experienced anything like this I’d like to hear your thought 🙂

    kind regards,

    -T

    #1025
    Veronica

    Hello T.

    Thanks for raising the issue. I searched our Knowledge bases and could not find any evidence for the reported issue.
    Please not that our software is monitoring the usage for license Servers, however we do not have access to the data and logic as used by then license Server

    #1026
    hl

    Hello Nadav,

    thanks for replying.
    what do you advise then?
    I feel kind of stuck as logs doesn’t produce enough knowledge to debug moreover as it doesn’t happen all the time
    maybe this will be more informative:
    SLI => override feature list set to ‘ VIP-AMBA-AXI-SVT VIP-AMBA-APB-SVT ‘
    SLI => received port 48682 and parent pid 5612 as arguments
    SLICOMMON => sli_server_socket
    connect: Connection refused
    connect: Connection refused
    connect: Connection refused
    connect: Connection refused
    connect: Connection refused
    SLICOMMON => sli_server_socket: could not connect to socket provided by client
    SLISERV: Fatal error – unable to connect to socket.

    -Tal

    #1028
    Willie

    Hi Tal,

    Can you set the Environment Variable FLEXLM_DIAGNOTICS to 2 on the application machine. Then try the application again. This should product a flex###.log if there is a licensing problem that occurs.

    FLEXLM_DIAGNOSTICS is an environment variable that will cause the application to produce diagnostic information when a checkout is denied. The format of the diagnostic information may change over time.

    If FLEXLM_DIAGNOSTICS is set to 1, then the standard FLEXlm error message will be presented, plus a complete list of license files that the application tried to use.

    If FLEXLM_DIAGNOSTICS is set to 2, then, in addition to level 1 output, the checkout arguments are presented.

    If FLEXLM_DIAGNOSTICS is set to 3, then, in addition to level 1 and 2 output, if a checkout is successful, information is printed explaining how the license was granted:

    #1030
    hl

    Hey thanks for replying mate!

    where would you set ‘FLEXLM_DIAGNOSTICS’ ? inside the license file ? or in the ‘module’ file ?
    could you share an example please?

    br,

    Tal

    #1031
    hl

    Hey,

    I got it
    setenv FLEXLM_DIAGNOSTICS 5
    I actually found some more ENV vars
    setenv SLI_DEBUG_SERVER 1

    thanks all for the help

    #1032
    Willie

    Hi Tal,

    To set the environment variable settings on Windows:

    On the windows search box, Enter in “environment variable”. The System Properties window should appear. At the bottom, you should see a box “Environment Variables…” Click on that.

    You can then set a System or User Variable. Click on “New”.
    For the Variable Name, type in FLEXLM_DIAGNOSTICS
    For the Variable Value, put the number of the level
    Then click on OK.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.